android applications not working any more

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By zen3001

I had a platforming game exported and it was working a while back without problems, other than some ingame bugs. but at somepoint when exporting a new version of the game the game it won’t load any more, I see the godot splash screen with a white background(even tho I have set a custom one with a grey background) for a second and then the screen sets into grey closer to the back ground color of the game and the splash screen and nothing else. just a grey screen. so I tried exporting my previous version again and it won’t work anymore either! wth?

EDIT: looked in the console log of the engine when I compile the game, there’s a warning that might mean something

This jar contains entries whose certificate chain is invalid. Reason: PKIX path building failed: unable to find valid certification path to requested target
This jar contains signed entries that are not signed by alias in this keystore.
This jar contains entries whose signer certificate is self-signed.
This jar contains signatures that do not include a timestamp. Without a timestamp, users may not be able to validate this jar after any of the signer certificates expire (as early as 2047-05-20).

no clue what any of it means

And I guess you have no error messages either. What changed since the last time your game was working? Did you upgrade Godot? Did you mess with any settings such as Androi permissions? Do you have the previously exported apk? Does it work?

Maybe you will have to go step by step an see what is at fault here. Make sure to test the game on your device before exporting it using the editor.

johnygames | 2019-12-30 18:15

it’s working fine in the editor, previously exported games are working fine too. the only changes I made are compiling the debug and release templates with the admob module.

zen3001 | 2020-01-01 13:47

update, I tried exporting it as desktop application for windows, the game works fine that way but for some reason the custom icon I made won’t be exported with the application, instead there’s the default godot icon.

zen3001 | 2020-01-02 16:25

About the android thing, It must be Admob, which I know nothing about, As for the icon, people often have problems with that. Search the forum for questions related to this topic, you’ll find plenty of suggestions.

johnygames | 2020-01-02 22:27

exporting without admob doesn’t make any difference, still gives the same result.

zen3001 | 2020-01-02 22:46

Do you have an internet connection? Maybe if you updated you jdk and android installation?

johnygames | 2020-01-02 23:16