Android Export - Error type 3: Activity class {} does not exist

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Wiskam
:warning: Old Version Published before Godot 3 was released.

Hi !
I’m trying to compile my game to Android for the first time (never done that before). Basically I get an error when I’m trying to use both “One-click deploy” icon and “Export” tab.

What’s the issue ?:

  • When I export my game for Android, everything works except I’ve an error in the Godot cmd window that says
"Error type 3: Activity class {com.godotengine.myproject/org.godotengine.godot.Godot} does not exist"

The APK file is created but when I install it to my phone and launch my game, the app crashes after the Godot splash screen.

  • When I try to play my game through ADB, I get this error:

The game doesn’t start and the icon is nowhere.

What I’ve done / tried?:
I’ve followed the “Exporting for Android” doc, and set up the adb, jarsigner and keystore locations in the “Editor Settings”.

I’ve set up the “Project Export Settings” with things about my project.

I also tried to install both JDK 7 and JDK 8 to try both separately and the same thing happens.

I tried with my phone which is on Android 5.0.1 and another one which is on 4.4.2 and same result happens with both of them.

I tried to use the One-click deploy thing on an emulated android device (with ADB) and also with my phone connected by USB. Issue explained before happens with both.

Thanks for reading, I hope you will give me some tips to solve this issue.

what adb log says?

volzhs | 2016-05-20 17:43

Thanks for your answer, well I see only some errors like

E/Vold    (   53): Error creating imagefile (Read-only file system)
E/Vold    (   53): ASEC image file creation failed (Read-only file system)
E/PackageHelper( 1073): Failed to create secure container smdl960120085.tmp
E/memtrack( 1097): Couldn't load memtrack module (No such file or directory)
E/android.os.Debug( 1097): failed to load memtrack module: -2

But since I’m not really an expert, I pasted the logs entirely on just to be sure I don’t miss something due to my unfamiliarity with this.

Wiskam | 2016-05-20 18:41

Do you call your debug keystore release.keystore? And you keep your release keystore under the Java JDK directory?

duke_meister | 2016-05-21 00:16

That was a test, I created first a simple debug.keystore, I tried with a release.keystore with infos customized (alias, storepass, …) but nothing is working, same issue so it’s not about the keystore I think.

I also tried to change the location of the keystore and specified it into the “Editor Settings” but same issue again and again: Activity class {} does not exist.

Do I need to give more information about my problem to get help, what else do you need to know ? Maybe I forgot to show something, I can do it if you tell me what you need.

Thanks again for your help.

Wiskam | 2016-05-21 12:16

:bust_in_silhouette: Reply From: Wiskam

ISSUE SOLVED by deleting the “Godot” folder in “AppData”, and deleting the godot.exe.

I’ve downloaded again the Godot file, launched it and configure everything again and the issue never came back again.

Too bad I didn’t find the cause of this issue, but well it’s fixed now, I guess it’s a good thing. Didn’t really had the time to find the problem.