Animated Sprite2d gets misplaced in Fullscreen in Title screen

guys i placed a scene of my campfire in my main menu and it looked great in window mode, but when i make it Fullscreen the campfire gets misplaced.
This is it in windowed mode:

This is it in fullscreen:

This is the layout of my things:
probshow

Can you please send a picture of the 2d view?

From what I can tell, your control node (Mainmenu) has its anchor in the upper left of the screen. This would cause the offset of the CampFire to be positioned relative to the upper left corner.
There are two ways to fix this:

  1. In project settings, lock the window size to the size you have.
  2. You can probably change the anchor to the full screen using presets (see here, full rect). This might break everything, though, so I would first try adding another regular control node as a parent to the CampFire node and setting it’s anchors to be the full screen.

Hope this helps!

It is full rect in the mainmenu. Maybe the only way is to make it full screen

Try the control node parent and having it not full-screen, but instead having it ‘centered’, keeping the campfire in the center of the anchors, but moving all 4 anchors to where you want it in the scene. The problem to me seems to be the fact that it is a Node2D inheritance and not a Control node inheritance.

It didnt work. Thanks for helping tho

What is your stretch mode and stretch aspect? (ProjectSettings > Window > Stretch) Since your CampFire is a Sprite and not a Control node, its position is relative to the upper left corner, and (by default) won’t scale with the window.

I figured out a way to make it work. I created alot of images and animated them in texture rect with the animationplayer