AnimationPlayer2D keeps spamming errors when changing part of property (position:y)

Godot Version

v4.2.1.stable.official [b09f793f5]

Question

I was super happy when I discovered individual properties of nodes can be accessed in AnimationPlayer (for example, if I want to change only A in RGBA).

Right now, I’m using AnimationPlayer2D to slide a particular scene to a particular position, like this:
image
And this works great in game! (As in, the object behaves exactly like expected etc) But the problem is that in the IDE, this keeps spamming the console with an error:

Could not determine track hint for 'leg R:position:y" because its base property is null

I’m not sure why is this error constantly triggering? I used the same technique in other parts of the project and there it works without any problems.

did you get the key property from the inspector dock, or just typed it in?

From what I know it’s not possible to make a track for only a part of the property (for example, for y from xyz only) from the inspector dock. The way I added it was:

  1. Added a track
  2. Selected “leg L” from the popup that appears
  3. Selected “position” from the list of properties (this adds a vector2 track for both position x and y)
  4. Changed this track by adding “:y” to it

i think you can do something like this
image
go to + Add track
select Bezier Curve Track
image
then select the node you wanted to animate, pick position property

it should show position:x and position:y
then delete the position:x
leaving you with position:y like you wanted

This achieves the same result as if I typed it, right?
In any case I just tried it and it keeps printing errors.

it doesnt, i supposed, follow the step, it still got an error?

I did exactly as you suggested. What you proposed adds the same property as if I typed it. And yes it still produces the error.