Connect 2 RigidBody2Ds with a PinJoint2D

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By bruteforce
:warning: Old Version Published before Godot 3 was released.


I am trying to connect nodes for the first time.
I have 2 rigidbodies and 1 pinjoint, the project looks like this:
enter image description here

The problem is, that the two bodies are overlapping, and do not stop when (the collisionshapes) reach each other.
enter image description here

How can I fix this?

Thank you!

:bust_in_silhouette: Reply From: YeOldeDM

Disable Exclude Bodies on your pin joint.
You can see it there right below where you set the nodes.

Exclude Nodes :wink:

Tetane | 2017-02-23 20:03

Ahh! I’m blind!
Sorry for the RTFM question, and thank you :slight_smile:

bruteforce | 2017-02-23 20:34