Godot crashes if I play the scene. How to fix?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Crispian Tory

Here’s the error log :

Project “MyFirstGodotGame.sln” (Build target(s)):
Message: Building solution configuration “Tools|Any CPU”.
Project “MyFirstGodotGame.csproj” (default targets):
C:\Program Files (x86)\Microsoft Visual Studio\2019\BuildTools\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets(1175,5): error MSB3644: The reference assemblies for .NETFramework,Version=v4.7 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at .NET SDKs downloads for Visual Studio [C:\Users\A\Desktop\My Projects\My Godot Projects\MyFirstGodotGAME\MyFirstGodotGame.csproj]
Done building project “MyFirstGodotGame.csproj” – FAILED.
Done building project “MyFirstGodotGame.sln” – FAILED.

… I tried downloading the Mono, it has no effect… Then I tried downloading the right .NET Framework sdk for Godot and still I have this error. Also I already have visual studio with build extension. This is my first time using the engine and Im only a beginner programmer and have absolutely no idea how to fix.

:bust_in_silhouette: Reply From: ondesic

I just noticed your post. I hope you figured this out. I am always sad when I post a question here and no one answers.
This problem can be so frustrating and I encountered it myself. Here is the link to another user’s question that I answered. Look for the post by “ondesic” at the bottom.
solution