Godot editor look grey

Godot Version

Gôdot 4.2.2 Android editor


Good morning,

I use Godot 4.2.2 on an Android smartphone to develop a 3d game. I want to use mobile rendering mode but the interface turns gray in this mode.

With compatibility or forward+ mode, the interface works correctly.
Does anyone know how to resolve this problem? Thank you so much !

Good morning,

I just noticed that I could switch from mobile mode to compatibility mode after creating the project, by switching to compatibility mode the interface becomes normal but by switching back to mobile mode the interface becomes completely gray again.

Thanks for your help.

Check the colors in Editor > Editor Settings > Themes

hello, thank you very much for your help KingGD,

I went to look in the theme, I tried to manipulate the settings but that didn’t solve the problem. However, I discovered a strange fact, the colors don’t seem to appear in the mobile version!

Is there perhaps a problem with godot’s color management or display system?

Thanks again !

There are some theme presets, try this

I’ve tried most of the pre-made themes but that doesn’t solve the problem.

What surprises me the most is the link between the mobile optimization mode and the godot interface, shouldn’t that be related?

thank you very much for your help KingGD!