Godot has stopped recognizing my GPU.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Socrates

I’m not sure why this has happened or what i could have done to cause this, but Godot has stopped using my discrete GPU (a GTX 1050 ti) and instead just uses the integrated Intel GPU. Is there a config file or a setting somewhere where I can change this? It occurs with both the 3.0 and 3.1 branches (I’ve tested it with the alpha download, with Calinou’s nightly build, and with my own build). When I start Godot or start a project from within the editor it says: “OpenGL ES 3.0 Renderer: Intel(R) HD Graphics 630” where previously it was giving the name of the Nvidia GPU.

Found the answer here: How can I force Editor to use correct GPU? - Archive - Godot Forum

Still don’t know why it stopped using the discrete gpu, but it works now.

Socrates | 2018-10-07 15:38