Godot will not run on my computer

Godot Version

4.2.1 stable

Question

Hi, I’ve used Godot for a while but I’m not that experienced in it, I’m still learning its features. I’ve run into an annoying issue where Godot just refuses to run on my laptop; the project manager will launch, but if I try to open a project or create a new one, it just closes itself after freezing/loading for a couple of seconds.

I had to use a different computer to even be able to use the program for a while, but the recent update made me wonder if maybe I could start using it on my own computer again? Well, I wouldn’t have created a forum account to make this post if that was the case. Does anyone else have this issue?? And how can I stop this from happening in the future?

Hello!

Would you mind sharing your computer specs?

Have you tried with different renderer options when creating a new project?
image

Here are my pc specs:
image

And yeah, I’ve tried creating projects with the renderers but they didn’t work either. I also want to mention that before making this post, I tried resetting the program to a “clean install” by deleting the Godot folder in my appdata/roaming folder and running the app again, which worked, but it didn’t solve the issue which leads me to believe it is something with my laptop. Now instead of it crashing when creating a new project, it crashes when I open the asset library like it prompts me to, since there are no projects.

Are you trying Godot 4.x?

Have you tested whether the same happens with godot 3.x?

EDIT:
please, hide the IDs shown in the picture.
Thank you.

Didn’t even think about the IDs in that picture, thank you for that.

Yeah, the version I was trying before was version 4.1.3, and then the latest version 4.2.1 today; neither worked properly on my computer.

As for version 3.x, I just downloaded and ran the current LTS build and it seems to work perfectly fine.

Have you updated your drivers recently?

As you haven’t shown any, I assume you don’t have a GPU, just the integrated GPU from your i7 chip.

Try that maybe if you haven’t, and report back :slight_smile:

i am also having similar issues;
Godot version 4.2.1

|============================================|
my system info:
System:
Kernel: 6.1.0-17-amd64 arch: x86_64 bits: 64
Desktop: Cinnamon v: 6.0.4
Distro: LMDE 6 Faye base: Debian 12.1 bookworm
Machine:
Type: Portable System: Dell product: Precision M6500
CPU:
Info: dual core model: Intel Core i5 M 560 bits: 64
Graphics:
Device-1: NVIDIA G92GLM [Quadro FX 2800M]
driver: nouveau
Display: x11 server: X.Org v: 1.21.1.7 with: Xwayland v: 22.1.9 driver: X: loaded: modesetting
unloaded: fbdev,vesa dri: nouveau gpu: nouveau
API: OpenGL v: 3.3 Mesa 22.3.6
renderer: NV92 direct-render: Yes
|==========================================|

Godot does open the project list, however, any project, regardless of whether it was created with Forward+ or compatibility causes a crash to desktop;

running with the following option:
./Godot_v4.2.1-stable_linux.x86_64 --rendering-driver opengl3D

also causes the same crash;

I’ve pasted the output from the terminal below:
================================================================
handle_crash: Program crashed with signal 11
Engine version: Godot Engine v4.2.1.stable.official (b09f793f564a6c95dc76acc654b390e68441bd01)
Dumping the backtrace. Please include this when reporting the bug to the project developer.
[1] /lib/x86_64-linux-gnu/libc.so.6(+0x3c050) [0x7f25d20d4050] (??:0)
[2] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0xcb8f2f) [0x7f25cd4b8f2f] (??:0)
[3] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0xd860ed) [0x7f25cd5860ed] (??:0)
[4] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0xcc30ee) [0x7f25cd4c30ee] (??:0)
[5] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0xcc31f7) [0x7f25cd4c31f7] (??:0)
[6] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0xd7c564) [0x7f25cd57c564] (??:0)
[7] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0xcc1f35) [0x7f25cd4c1f35] (??:0)
[8] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x99859c) [0x7f25cd19859c] (??:0)
[9] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x9a158d) [0x7f25cd1a158d] (??:0)
[10] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x182ddd) [0x7f25cc982ddd] (??:0)
[11] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x18367d) [0x7f25cc98367d] (??:0)
[12] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x183c9c) [0x7f25cc983c9c] (??:0)
[13] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x184198) [0x7f25cc984198] (??:0)
[14] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x341209) [0x7f25ccb41209] (??:0)
[15] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x33e355) [0x7f25ccb3e355] (??:0)
[16] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x32c9bc) [0x7f25ccb2c9bc] (??:0)
[17] /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x30410b) [0x7f25ccb0410b] (??:0)
[18] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x1065ab6] (??:0)
[19] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x106877d] (??:0)
[20] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x1069b60] (??:0)
[21] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x107fc08] (??:0)
[22] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x108e813] (??:0)
[23] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x368c3d9] (??:0)
[24] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x3691cf5] (??:0)
[25] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x3642df7] (??:0)
[26] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x365c446] (??:0)
[27] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x314a816] (??:0)
[28] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x4fab02] (??:0)
[29] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x41ed28] (??:0)
[30] /lib/x86_64-linux-gnu/libc.so.6(+0x2724a) [0x7f25d20bf24a] (??:0)
[31] /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0x85) [0x7f25d20bf305] (??:0)
[32] /home/foxltdeb/Downloads/applications/Godot_v4.2.1-stable_linux.x86_64() [0x42aa6a] (??:0)
– END OF BACKTRACE –
================================================================

That command line is wrong.
It should be
--rendering-driver opengl3

Please don’t hijack the question @heater19 . Make your own post or wait for resolution. You may have an entirely different issue. Please search the forums as this has come up many times. The last line mentions glibc, please check the library version is 2.32 or higher for your Linux distro.

I also couldn’t find out if your cpu from 2010 can even supports opengl.

https://www.intel.com/content/www/us/en/products/sku/49653/intel-core-i5560m-processor-3m-cache-2-66-ghz/specifications.html

Looking a little deeper @heater19 your graphics only supports opengl2.1, which means you can only run Godot 3.x, as opengl2 support was dropped from Godot 4.

Maybe your Nvidia Quadro could technically run opengl 3.3. but man your hardware is pushing it.

@gopper, unfortunately your 10th gen integrated graphics doesn’t support Godot’s Vulcan 1.3 driver, it only goes up to 1.2.

You will need to run in compatibility mode which is opengl 3.

You can test this by running the editor via command line with the --render-driver opengl3 option.

I’m going to old posts about vulcan issues. you should try and install the latest graphics driver for your cpu. If you still have a vulkan issue please share it with github.

https://www.intel.com/content/www/us/en/search.html#sort=relevancy&f:@tabfilter=[Downloads]&f:@stm_10385_en=[Graphics]