GpuParticles - Problem with trails

Godot Version

4.2.2

Question

So when I enable trails on my gpu particles and set lifetime to 0.01 it’s all good in the original scene but when i istantiate it in the main scene the trails don’t match and are way longer like it goes back to default trail lifetime setting. What’s up with that? Is it some kind of bug or am I doing something wrong. Maybe hard coding the lifetime will help instead of setting it up in the editor?

Are the GPU particles saved to a separate scene and then instantiated? If so, you wanna make sure the lifetime is set to 0.01 in the particle scene because changing properties on an instantiated scene inside of another scene will only change the properties of that instance.

I wish that was the case but I can confirm it’s set to 0.01 in the particle scene and then the instance “resets” the value. I played with it a bit and the only way I could make it work was to turn off trails in the editor and then in the script enable it on _ready and set the proper value. Don’t know why but at least it works :smiley: