Help with get_node function

Im a noob lol
Screenshot 2024-01-02 220153
Im in the Script that is attached to Level-Logic and try to change the texture of the Flags node. Whne I use get_node(“UI/UI/Flags”) I get an error saying that the node was not found.
Am I missing something?

There are several options, and it depends on where you are accessing it from (I think), relative and absolute paths. try Ctrl + Space = Autocomplete

% is unique node

Which version are you using?

Screenshot 2024-01-02 223420
It for some reason only gives me that

Godot .NET 4.1.2

me v4.2.1.stable.official, without .NET, maybe it works better in the new version

I cant switch version since its part of a school project with other people

The thing is, I used get_node many times before and it always worked thats why I am so lost finding out why it does not work in this situation (sorry my broken english)

My english is not better :slight_smile:

Hard to say without having the project, can you reproduce the problem in a small project, compress it with zip and share it on Google Drive for example?

I just created a new script which is directly attached to the Falgs note and therefore was able to make it work in the end. i just worked my way around it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.