How do I align the bottom of my 3d player model perfectly on top of my 3d floor model?

Godot Version

4.2.1

Question

Making a 3D game. I want to place the player model in such a way that it’s not slightly hovering above the floor, and not sort of clipping through the floor either. Is there some command or something I can do so that it’s perfectly on the floor?

In the editor there is a “snap object to floor” option while an object is selected, the keyboard shortcut is pagedown. Default editor shortcuts — Godot Engine (stable) documentation in English

If you get things it aligned in the editor that way, afterwards any dynamic movement at runtime, e.g. moving up slopes, jumping on different height objects, should still be set relative to that same height.

1 Like

Thank you, the page down shortcut worked.

I’m confused on what you meant by the second part - what do you mean by “if you get things it aligned in the editor” and “being set relative to that same height?”