How i fix this visual bug

godot 4.2

I’m not sure what’s happening, could you explain more?

1 Like

the models when they are far away and pass each other they start to “blink”

I believe that is Z-Fighting an inherit issue in computer graphics, maybe increasing the LOD bias can reduce this effect if it’s only happening on far away objects.

2 Likes

but is this the only way? Why don’t I see this in other engines?

This is an issue that shows up in other engines as well depending on your setup

ok, so if someone plays on a better setup than mine will these effects be reduced?

No not a hardware setup, but game setup and settings

Unless your GPU switches to a different floating point standard (it will not) you will have Z fighting when models are too close to each other, including with a low FOV and high distance. You may be able to tweak your camera’s near and far parameters for your game and target distances, I think lowering the far might help; that depends on how Godot handles the view matrix.

1 Like

ok, what would be the ideal configuration?

It depends on your case, there’s no magical solution, you need to adjust based on your situation, as always

ok, I’ll see what can help

Some solutions:

  1. Move models farther apart/deeper into the ground
  2. Increase LOD to prevent unwanted mesh deformation
  3. world triplanar texturing if both objects use the same material
  4. tweaking near/far cliping on the camera
2 Likes