How to turn off texture filtering with qodot

Godot Version

4.2.1

Question

I have no clue if this is the right place to ask this but here goes. I’ve been trying to disable texture filtering with Qodot with no success. I’ve also turned texture filtering in the rendering settings to nearest, but it doesn’t work for some reason.
If anyone could help, that would be great.

I’m not super familiar with Qodot, but digging through its docs a bit it says you can modify the textures it imports via the import dialog:

It also links to some explanation of how it gathers textures from TrenchBroom, so that might be of some help as well. ← actually that link doesn’t go anywhere…

I tried changing the settings in the Import tab and nothing changed.

Okay I figured it out. I just needed to change the material properties in the entity_0_mesh_instance.

1 Like

Better documented solution for those interested:
Head to the QodotMap Node in your scene, then go to Materials > Default Material > Sampling > Filter,
then change it to “Nearest”