Hue Variation in GODOT 4 for CPUParticles2D not working

Godot Version

<-4.2.2–>

Question

Can you please provide more context?

In GODOT 4.2.2, using the CPUParticles2D node, I cannot get the Hue Variation to work. The color stays the original color. Does anyone know if there is a bug, is there a fix, or am I doing something wrong? I set a difference between min and max variation but nothing happens.

try these settings:
variation min: 0
variation max: 1
variation curve (create a new curve but don’t change it)

your particles should change color, just tested that on new cpuparticles2d in an empty scene, there was no hue variation until i created the curve, so maybe that’s the missing ingredient for you.

also there was no variation if ‘variation min’ was also 1, the closer min got to max the less overall variation there was so go with 0 and 1 for meow.

Should work without a curve. Please report the issue here Issues · godotengine/godot · GitHub

Thanks…creating the curve worked. I appreciate your effort.

1 Like