I reimported a scene and now all my scenes open this

Godot Version

4.0

Question

When exporting the game for Windows, it does not open due to “lack of materials for a scene”, so I decided to reimport it and now every scene I try to open gives me this message, but there is no error, when I try to correct it, the dependency is correct .

You need to explain this more. This makes no sense. What are you exporting and what is giving the error?

I was able to solve it, it was a kind of chain error. Each scene had a PackedScene of the next, so if one failed, the previous ones failed. I had to delete the scene where the error started, import everything again, with the same name and it fixed itself. The truth is that it is a bit meaningless.

I still don’t understand what caused the error, I think it was some bug. I’m sorry if I didn’t explain myself well, it’s not my native language.

What I was exporting was my complete game for windows, from godot.
And what was giving me the error, I’m still not clear. At least what I did worked.

Anyway, I still get this error when exporting the game. If I run it in the engine I have no problems, it only happens when exporting.

Your export templates may be out of date. If you’ve updated Godot or use a way to update it automatically, your export templates may have not been updated the same way. You can safely delete them and re-download them. Ask if you need more help doing that. If that doesn’t solve the issue, I am not sure what the problem could be.

1 Like

Thanks, I just updated them. I’m still having the same problem. I highly doubt that it is the specific scene, I have already reimported it several times in different formats and it still gives the same result. And like I said, this only happens when exporting.