Just trying to get started - cant see Editor button

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By markeaston


I am evaluating GoDot with C#. I have installed Mono and downloaded GoDot Mono. When I run the GoDot exe, Godot_v3.0.6-stable_mono_win32.exe, it provides a dialog. In the instuctions it says … “While Godot does have its own scripting editor, its support for C# is kept minimal, and it’s recommended that you use an external IDE or editor, such as Microsoft Visual Studio Code, or MonoDevelop, which provide auto-completion, debugging and other features useful when working with C#. To set it up, in Godot click on Editor, then Editor Settings. Scroll down to the bottom, to the Mono settings. Under Mono click on Editor, and on that page choose your external editor of choice.”

Well in the dialog i cannot see the Editor button at all. There is not much - just a Project List tab and a Templates tab and a few menu items. But not much else.

Am I in the wrong place? I cant see any other app nor reference to anything else I should be running. Or are these docs wrong?

Help please … I am just trying to get started with developing a small test in C#.


You probably went into the submenu of project, make sure you select from the top “Editor>editor settings”. Now under “mono> editor” select external editor.

Badger | 2022-04-19 15:23

:bust_in_silhouette: Reply From: flurick

In the Editor Settings→General there is the category Text Editor→External if that is what you could be looking for