LightOccluder2D covers canvas item

Godot Version

4.2.1.stable

Question

I have tried every variation of Range / Shadow / occluder layers and can’t seem to get this to work. The light always covers the face of the object. I found the issue reported here, was this ever resolved? Is there a workaround besides doubling up the lights? I am using Tilemap, and I’d like it to apply like this to every object.

I think I had something similar. Have you tried changing the cull mode?
image

That didn’t work for me. This definitely used to be a feature, maybe I’m not figuring it out right. I found this video. The description reads

Testing a pixel art sprite with normal map with Godot Light2D and Occluder2D. To make shadow not casting on top of sprite, you need to use both “Item Cull Mask” option for “Shadow” and “Range”. “Shadow” mask determine which layer to receive shadow. “Range” mask determine which layer to receive light.

Why have these options if the shadows are just going to draw over everything