Lights are not visible in android.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Suleymanov

Lights are not visible in android. Also tried it in GLES2 to no avail. The only light happens to be from the default environment source, though without casting shadows. Is it the engine shortcoming or am I supposed to check/uncheck something before exporting to android?

Thank you for your time!

:bust_in_silhouette: Reply From: Microices

Try to enable the option in project setting and then export.

  1. open project setting
  2. Search for HDR
  3. Check hdr options
  4. close
  5. perform android export

Hope this works.

Thank you for the reply!

Checking didn’t help, unfortunately. I even maximized the light energy to see if that makes difference, still no success. It works well on desktop though.

Suleymanov | 2021-03-05 12:50

Hey! Your suggestion gave me an idea (to uncheck some of the .mobile properties) and voila! Disabling - Force Vertex - did solve the problem, though the lighting energy must be reduced significantly to look normal in Android.


Suleymanov | 2021-03-05 14:35

Great! Had not thought of that.

Microices | 2021-03-06 01:25

thanks for sharing, that worked for me to bro.

morningkingdom | 2021-10-03 12:35