Linux issue - The UI is so laggy!

Godot Version

4.2.2-stable
4.2.2-fedora
4.2.2-flatpak

Question

When I move or maximize the window of Godot or the game it lags out so hard!

When I disable KDE compositing using ALT + SHIFT + F12 it kinda solve the issue!

I’m using nvidia and at the latest drivers

RTX 3060
AMD Ryzen 3600 6 cores