Material Edge Seperation

Godot Version

4.2.2

Question

When importing a mesh into Godot from Blender the edges where the mesh changes materials (Dirt to Grass for example) the edges become separated with a clear gap through the geometry, it only seems to happen in to the edges that face certain angles in the X and Z axis. There’s no gap when modeling in Blender nor the Import window in Godot, only when the mesh has been set in the scene. The issue can be fixed by not exporting the vertex normals in Blender however this creates more issues with the texturing and lighting than it fixes. Any ideas on how this could be fixed?

An image would be helpful.

https://imgur.com/a/TNdLCnO

some examples of the artifacts. these only appear when in the scene, no where else. I get these issues regardless of file extension, GLTF, OBJ, DAE and even .blend

I’d say try toggling off the Optimize Mesh option for the mesh after import into godot, but if you are seeing it fine in the model window, that is interesting. Unless that smaller window it’s not just noticeable and the more higher contrast surface material color to the skybox color is just showing it?

I would check your material and see if you either have something going on there where it is offsetting the vertices on the mesh in anyway, do you see the same gaps when you just remove the material on the MeshInstance3D node?