MeshInstance3D not rendering on Android

Godot Version

4.2.1

Question

On Android with Compatibility renderer I’m trying to render Y Bot model from Mixamo.
It does render only on first run of the app. If I close and reopen it, the model is invisible. To make it visible again I have to uninstall and reinstall it or clear app storage from settings.

First app run just installed on Android:


(I can only put one embedded media)

What’s going on here?
Thank you.

Model inside Godot:
Model in Godot

Closing and reopening make the model invisible:

Which Android version is this? What is the model file (.glft, etc)? Can you reproduce the problem in a exported version for your OS (Win, Linux, etc)? It might be worth opening a bug case (or checking if one isn’t already open).

I’m experiencing this issue with my Pixel 6a with GrapheneOS (Android 14).

Tested it on my friend’s Samsung A13 Android 12 (OneUI 4.1) and it does not render anything but the background:

The Y Bot model is a .glb.
I got no Windows or Mac machine to try it on. On a linux exported binary there is no issue.

I only found this:
3D models not rendered on iOS with compatibility renderer
But I don’t think it’s related.

I don’t know how to debug this issue. Can you point me to somewhere?

Thank you.

You probably will need to report a bug, it looks similar to that issue you mentioned. Get the log file from Android and open a bug report.

Maybe you can try a simplier model, with a smaller polygons count?

How do I get/generate log on android?
Do you got any link to some documentation?

Probably you will need to enable developer options. See if this tutorial helps you collecting the logs:

1 Like

I will take a look as soon as I have time.
Thank you for your time.

1 Like

Dunno if this is what I am supposed to get (grep -i "godot"), it is very huge:
adb logcat

Anyway, while looking for USB Debug, I found inside Android developer options “ANGLE Preferences”.
Here there is a list of installed apps where I can select OpenGL Driver between “default”, “angle” and “native”.
If I opt for “angle” the model does render. If I opt for “native” the model does NOT render.

Why this happens? Can I fix this thru Godot options? I saw rendering/gl_compatibility/force_angle_on_devices but it’s only implemented on Windows.