Mouse sensitivity in the editor (O.S. setting have no effect)

Godot Version

4.2.1

Question

I just updated to the latest version and I’m having a hard time with the mouse sensitivity, both panning and zooming with the scroll wheel. I adjusted the Windows 10 sensitivty setting so that when I’m in any other app the scroll is very slow … but in Godot it’s unusable. For example, when I have a cube that is 1 unit wide that takes up less than 1/20th of my screen (in pixels) and I zoom in once it completely disappears as does the grid display. If I zoom out it’s just the size of a handful of pixels.

I can adjust the “orbital” sensitivity and that makes things manageable when I right click and orbit the view … but the pan and zoom are still way too fast. My OS sensitivities are at the lowest possible setting.

Godot doesn’t read the OS’ mouse wheel sensitivity settings, so these won’t have an effect in the editor or projects. The OS pointer sensitivity will affect Godot, except when in the Captured mouse mouse as it uses raw input. This is what freelook in the 3D editor uses.

Do you have Enhance pointer precision enabled in Windows’ mouse settings? You probably want to disable it, as mouse acceleration is generally undesired. (If you don’t see this option, press Windows + R and enter control mouse).

Ah, OK … thanks. But are saying Godot has it’s won settings? I don’t see one for zoom (an I blind?)

There’s no zoom sensitivity in the 3D editor currently, but if zoom appears to be too quick, it’s likely because you used panning or freelook to move away from the world origin and zooming is relative to the middle point (and not the world origin). Press F with nothing selected in the Scene tree dock to go back to the world origin.