Nearest not fixing blurry imports

Godot Version

Godot 4.1

Question

Am i importing blurry sprites or something? because I changed the project settings to “Nearest”.

please work with me i will answer questions and clarify everything. Ive been removed from stack overflow after 3 questions… so please just help and not downvote or remove me into oblivion

Did you set the texture filtering on the sprite to none and render it at an integer position?

I could try that, where would that setting be?

Are you working in 2D or 3D? The default texture filter project setting only affects 2D elements, not 3D.

OOOOO thank you, i am in 3d, im very new So i did not know that, is there a way to import my Sprites and put them onto 3d things and not have any stretching/Distortion/Blurry affects?

try set texture filter to linear

You need to set the filter to Nearest on each StandardMaterial3D, as there’s no project setting affecting this globally.

For imported 3D scenes, use the script mentioned here: Add a Default Texture Filter project setting for BaseMaterial3D, SpriteBase3D and Label3D · Issue #5228 · godotengine/godot-proposals · GitHub