Node not found

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By givenmnisi6

I get this error

@ _ready(): Node not found: “AudioStreamPlayer” (relative to “/root”).

Post the following:

  • The offending script
  • The structure of your scene tree
  • Indicate which node in the tree the script is attached to

jgodfrey | 2023-06-10 23:59

Here, I hope this helps, it’s line 15. Here is the photo of the Scene, it’s a Google Drive link since I cannot put a photo here

Quiz Scene

givenmnisi6 | 2023-06-11 00:06

The posted image isn’t accessible…

jgodfrey | 2023-06-11 00:08

Try the link there

givenmnisi6 | 2023-06-11 00:09

Nope - that leads to a “You need access” message.

jgodfrey | 2023-06-11 00:10

Please try again, I made it accessible to anyone with the link

givenmnisi6 | 2023-06-11 00:12

When you create the link on Google Drive, you need to change the General Access from Restricted to Anyone with the link.

jgodfrey | 2023-06-11 00:13

It should work now

givenmnisi6 | 2023-06-11 00:15

OK, I can access the image…

Where is the AudioStreamPlayer node? It doesn’t appear to even be part of the scene in your image… If you’re trying to directly access a node that falls outside the current scene, that’s probably not advisable…

jgodfrey | 2023-06-11 00:17

Oh, I see, there is supposed to be a node before getting it. I understand. Thank you so much. I will also put the images of the last question about minimizing etc.

givenmnisi6 | 2023-06-11 00:22