Question, does it make sense to move from 3.5.3 to 4.* if you make html5 games on itch

Godot Version

3.5.3 > 4.*

Question

Question, does it make sense to move from 3.5.3 to 4.* if you make html5 games on itch

If you want to create a new project, consider creating it in new version of godot, currently 4.2.1

Godot 4 contains many fixed bugs, improved performance, new features, helpers etc.
So I think it makes sens to create projects in newer versions of godot if possible, 4.2.1 is pretty solid

1 Like

Thank you so much for the detailed reply!

1 Like

Hi! Just to add, the only reason I wouldn’t use Godot 4 for a web game would be if I was using the .net version to allow me to use C#. Currently you cannot export web games with this.

However, if you’re using the main version of Godot, then there are no issues!

1 Like

Thanks for the advice!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.