Remote Debug doesn't have an option for Oculus Quest 2

Godot Version

4.2 stable

Question

I followed the instructions in this video: “Godot Export To Meta Quest 2” without a problem.
Except when I am expected to continue in the headset, I cannot because the Remote Debug button doesn’t give me the option for Oculus Quest 2.
Unfortunately, the video doesn’t mention this at all.

Any hints will be greatly appreciated.

DPC

Is your headset connected to the PC with USB debugging enabled (or wireless debugging)?

USB debugging is easier to get working compared to wireless debugging, but it requires you to have the cable connected until you deploy the project on the device. You can disconnect the cable after the project is deployed (Godot’s debugger works over Wi-Fi).

Thanks for replying Calinou.
I did enable the USB Debugging, but I still do not see the Oculus Quest 2 option showing.

However, I found a newer video tutorial:
Getting Started with OpenXR in Godot (updated version)

It seems very promising. I’ll have a look tomorrow.

DPC

And of course, I spoke too soon! :frowning:
As soon as I reached the “Testing our project” part of the video I could see that was as far as I was getting. I clicked on Run Project and I get an Alert notification:

image

Any ideas?