Same code, different result

Godot 4.2

Hi, i copied a code from github to get a first person control to my player,
When i play on his project, i can use mouse and controller, but when i play on mine, i can only play with my controller, even though we have the exact same code: GodotFirstPersonController/Player/player.gd at v3.1.1 · rbarongr/GodotFirstPersonController · GitHub

Hi, when you say copied, do you mean that you cloned the project or that you used copy and paste to fill in the scripts?

Yes, actually i tried some other thing and i think the problem come from the mouse capture, because when its captured the game doesnt know i move my mouse idk why…

Sorry, when you say yes, which part of the my question are you referring to? Did you clone the repo or did you copy and paste text into script files?

I copied past, then i modified everithig to make a third person camera to see if maybe idk why it would work, i added this script down below and same problem:
i run his project it work
i run mine it doesnt…

Hi, I ran your code and it seems to work. Did you find a solution? I see you marked it as solved.