Scene not opening in editor, but still able to run

Godot Version

4.1.1

Question

I was trying to reorganize the files of my project, it stopped working, so i just put all the files back exactly as they were, and everything worked perfectly, except the main scene i was working on, it will run fine using “Run specific scene” and also when switching to it from another scene using getTree().change_scene_to_file
The problem arises whenver i want to open that scene to edit it, it will just give me an error saying 'Can’t open file “____” The file could’ve been moved or deleted. I’ve tried making a copy of the file and opening it, changing it’s location in the files,but none of that has worked so far, can anyone help figure out hwo i can fix this or at least be able to get the content of that scene onto another?

try reload current project option in project tab

have also tried that and the same issue pops up :confused:

ended up realizing that one singular ogv file that was originally in the scene had been moved, so i just put that back in place and it worked, just putting this here in case someone else has the same problem =P