Skeleton not showing up when importing model from blender

Godot Version

4.2.2

Question

I have a rigged hand model in blender that I’m planning to use on hand tracking for VR, but no matter how I try to import to Godot/ export from unity, the bones in the hand do not show up.

are you exporting the gltf with the correct setup in blender (like I forgot what the exact option is but where it exports the armature)?

Yeah, have tried all relevant combinations of export options too.

Have you tried opening the gltf after importing into godot to see if anything strange is going on like if it skipped the import of the Skeleton3D?

Not sure this is your issue, but it’s “normal” (or a known issue…) that the “end bones” are missing when exporting with gltf, you can add extra leaf bones in blender as a workaround:

This is not a Godot issue.
The Blender FBX exporter has an option Armature/“Add leaf bones”.
If used, Godot shows all bones visually, with their correct length.

Blender’s GLTF exporter doesn’t have this option, therefore the leaf bones are imported into Godot, but not shown.
The information about how long the leaf bones are, gets dropped on export by Blender.
The workaround is to add leaf bones in Blender manually.

The skeleton appears when opening the gltf after importing, the end bones are missing however.

No, sadly the entire skeleton is missing, not just the end bones.