Sprite region enabled keeps drawing extra border frames?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By 1izNoob

Whenever I enable the border region of a sprite and set a custom width and height Godot draws the frame of the border continuously, which looks horrible. Is there a way to disable that?

What do you expect it to do though? Draw empty pixels? You specified a region which is larger than the texture. What is the goal?
It does this because the texture’s border pixels on the right are not transparent pixels, they are blue pixels. And because the texture’s import settings don’t repeat by default, the right border just keeps being redrawn causing this sort of trail.
But without knowing what you really want, it’s hard to tell what you need to do.

Zylann | 2022-01-31 13:55

oh sorry, I just want empty pixels around it so I have space for shaders on the sprite

1izNoob | 2022-02-01 12:30

Yeah this is not how it works. You will really have to either add one line of pixels around so that it produces that effect, or you will have to deal with this in your shader somehow if UV is greater than 1 or lower than 0. The texture will either be clamped (like your screenshot) or repeated based on its import settings, but “new pixels” of a different value can’t be generated like this without changing the texture.

Zylann | 2022-02-01 22:03