Turning SSAO and SDFGI makes lines appear on viewport and on editor

Godot Version

4.2.1

Question

So without turning the SSAO and SDFGI on the lines will not appear. The lines remind me of old television lines. Restarting Godot will make the lines go away but they seem to come back randomly. Is this a bug or a bad setting? All SSAO and SDFGI settings are at their defaults.

Which OS and graphics card model are you using? Do you have MSAA enabled in the Project Settings? This may be due to Vulkan: Enabling MSAA with SSAO causes artifacts to appear on AMD Polaris GPUs · Issue #61415 · godotengine/godot · GitHub.

1 Like

I am indeed using amd rx 6800 with windows 11, MSAA is just at 2x.

As a workaround, disable MSAA and use another antialiasing method such as FXAA, TAA or FSR2.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.