VoxelGI not working with Blender mesh

Godot Version

4.2.1

Question

I can’t get VoxelGI to work with any model that comes out of Blender.

The box on the left is using MeshInstance3D boxes. The box on the right is using a Blender file dropped into the scene. The Blender mesh is made out of solid cubes, and Blender confirms there are no non-manifold meshes. The import settings for the Blender file are all default, the light baking is set to Static (VoxelGI/SDFGI).

Is there something that I’m doing wrong?