Why does my game boot to a weird unopenable white screen on my laptop?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By kreins

I downloaded godot on both my desktop and laptop. The desktop is old except for the graphics card, and the laptop is relatively new. (I’m new to this and trying to fool around with game dev.) When I run projects on the desktop, it works fine, but on my laptop (Dell XPS) I try to run a very simple project from the editor, and this happens:
white screen
Clicking on the window does nothing. This also happens when I make a completely blank project and run it immediately. Weirdly, there are two things that DO work.

  1. Running an example project from the editor (Specifically the 2D Platformer KinematicBody example)

  2. Running this project from the launch screen by selecting it and clicking “Run.”

I’m stumped as to what could be going wrong. If anyone has any ideas, I’m all ears, as I’d like to be able to switch between my computers to work on projects.

Someone please answer this. I am having this same exact issue with my laptop, and I posted about it on the Godot subreddit.

vader-coder | 2020-08-26 05:00

:bust_in_silhouette: Reply From: vader-coder

Try what GitHub user knadoor recommended:
“What is your monitor screen resolution?
If it’s high res, such as 4K screen (like mine) try this and see if it works:
1 - Under Project Settings search for ‘hidpi’
2 - In Display/Window, ensure ‘Allow Hidpi’ is checked
3 - In Gui/Theme, ensure ‘Use Hidpi’ is checked.
4 - Reload the scene.”
I tried this and it worked for me.