Why is my thing damping?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By captain_ghost

I have a RigidBody comprising a unit cube of mass 1kg at the origin. I’ve set linear_velocity and angular_velocity to zero, can_sleep to false, and I’m using custom_integrator. In my _integrate_forces() method I call state.add_central_force(Vector3(1, 0.0, 0.0)) and then print(str(state.linear_velocity)). I would expect my cube to be accelerating at a constant 1 m/s in the x direction, but instead I find the rate of change of velocity to be decreasing. Why would this be happening if damping is at zero? Any help is much appreciated…

It turns out that you need to set Default Linear Damp to 0 in the project settings. Setting linear_damp to 0 on the RigidBody object doesn’t disable linear damping. This seems like a bug to me, or is this intended behaviour?

captain_ghost | 2020-10-01 19:20