YSort doesn't seem to work on isometric tiles

Godot Version



I’m using a tileset with isometric tiles for my game. I turned on Ysort on the base node, the tileset, the tileset layer and the player and added a Ysort origin to the tiles I’m using.

But yet, Ysort doesn’t seem to work. I’ve searched it up and I really can’t find what I’m doing wrong.

Can you take a screenshot, I’d like more detail on it

Ok, this is what it’s doing. The bottom one is in-game btw

Try setting Y_Sort_origin.

I’ve done that already

Did I do it right?

Then try modifying Layers’ Y-Sort-Origin.

Yeah I also already tried that. Thanks for your help btw I really appreciate it

Ok I finally got it to work with some weird scaling on the actual tilemap. Once again, thanks for your help :slight_smile:

I have same issue, can you provide more info about fix?

I’m sorry that I’m a bit late. I’m definitely not really good at Godot, so I can’t promise that this will work. For me it worked when I scaled the tilemap to 1, 1. I think that Godot calculates YSort from the original scale or something. Did you also make sure that the layer you’re putting your tiles on is the same z-index as the player, and no individual tiles’s z-index is higher or lower?
I hope you already figured it out, but maybe this works

1 Like

Thanks for your reply!
Changing z-index on player and objects layer was the solution.

1 Like