[2.2] Can't deploy or test UWP

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Nuno Donato
:warning: Old Version Published before Godot 3 was released.

Hi everyone!

I’ve been trying to export one of my games to UWP using Godot 2.2 but with no success.
I followed the docs strictly, and everything went fine and I was able to export the final .appx from Godot.

But afterwards, it doesn’t seem to be recognized as a valid file (yes, I have sideloading enabled)
error when opening .appx file

So I went the other route and tried to run it directly via the VS project. set up everything according to the instructions, but when I run the project, I only see a green X window.X windows

I took a peak at a “terminal” that appeared to have been launched by the Godot executable and saw thisgodot output

VS just complains that something is broken but doesnt give useful info :confused:enter image description here

I hope I didnt mess anything up since the docs are still based on WinRT and not UWP. My only doubt was on editing the EntryPoint in the xml file, I’m not sure if I inserted the right name…

Any tips on how to proceed?

:bust_in_silhouette: Reply From: Shin-NiL

It’s a long time since I’ve touched my demo project. To make things worse, I can’t open my VS2015. Anyways, this is my EntryPoint config:

    <Application Id="App" Executable="godot.winrt.32.exe" EntryPoint="GodotWinRT.App">
      <uap:VisualElements DisplayName="Godot2" Square150x150Logo="Assets\Square150x150Logo.png" Square44x44Logo="Assets\Square44x44Logo.png" Description="Godot2" BackgroundColor="transparent">
        <uap:DefaultTile Wide310x150Logo="Assets\Wide310x150Logo.png" />
        <uap:SplashScreen Image="Assets\SplashScreen.png" />
:bust_in_silhouette: Reply From: vnen

After some tests, I think I know the cause why your exported project was not recognized as a valid package: the deflate method of the export template zip file.

Debugging the export process, I noticed there was an error when opening the zip file (don’t know if it’s a Minizip problem or if it’s on Godot side), so the AppxManifest.xmlwas empty in the final package. The export template was made with 7zip, which uses Deflate64 method as default. Changing it to Deflate solved the problem for me.

The VS error message is still a mystery to me.

Still wont work for me.
Here’s my 7zip screen when I’m creating the template archive
enter image description here

and here are the contents of the appx exported by Godot: [appx Contents] [2]

It’s strange, the AppManifest its not even there! I noticed this in the Godot console![enter image description here] [3]

Nuno Donato | 2017-05-14 07:48

Strange. What are the contents of your template? Does it have the AppxManifest.xml file?

It seems to me that the game files and the package files are mixed. Those errors hint that you have XML files inside your game project, and they shouldn’t be there.

vnen | 2017-05-14 12:56