2D: How to prevent tileset sprite from being affected by casted shadows?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Krydan

Hi there!

So I’ll get straight to the point. I have a Light2D on my player character, and a LightOccluder2D on my wall tile. Currently, the shadows being cast from a wall tile are overlapping onto the wall sprites next to it. Is there any way to prevent this, or to make the shadow pass under the sprite, perhaps?

LightOccluder2D settings:
Closed: True
Cull Mode: Clockwise

Picture of problem:

Picture of what I’m trying to achieve:

I’ve tried changing the Z-Index of the wall sprite (trying to get the shadow to pass under the sprite), to no avail. Maybe I’m doing something wrong though?

Any and all help would be appreciated!

Many thanks,

  • Dan
:bust_in_silhouette: Reply From: Grizly

How did you solve this problem?