2D Light shadow doesn't work

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By WelpHelp

Alright so I first tried 2D lightning with tilesets, I thought it was something wrong with my tiles so I made a new scene with just two sprites and a background, one sprite has the Light 2D node with the radial texture of light and the other one is a StaticBody2D with CollisionShape2D(and the sprite of course). I tried it with all these things, once I tried with just the sprite and no other nodes, tried switching from GLES3 to GLES2, shadows are ENABLED…and no one else seems to encounter this problem.

Is the non-light node using a LightOccluder2d?

Eric Ellingson | 2019-04-20 04:38

That was the problem, thank you!

WelpHelp | 2019-04-20 10:53

:bust_in_silhouette: Reply From: aniratepanda

Do you have an light occluder on your sprite? Try adding an occluder in addition to your collisionshape.