2D Occluders don't work on Android

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Pikmaan

I have a scene with some lights and one 2d occluder. It works well on my computer but the occluder doesn’t work on my Android device (Huawai H60-L04). I’m using godot 3.1 and I’m sure everything worked fine with the previus version. Also i have a lot of these errors (just with the smartphone):

E 0:00:00:0281   Condition ' status != 0x8CD5 ' is true. Continuing..:
  <C Source>     drivers/gles3/rasterizer_scene_gles3.cpp:5124 @ initialize()

Honestly I always ignored them because everything worked fine so far. I don’t know if they are relevant.

If i run it with GLES2 i got just one of these:

E 0:00:01:0238   Condition ' status != 0x8CD5 ' is true. returned: RID()
  <C Source>     drivers/gles2/rasterizer_storage_gles2.cpp:4841 @ canvas_light_shadow_buffer_create()

Can you try on 3.1.1? it got some fixes on the renderers, but if worked fine on 3.0 and is there on 3.1.1, it is a bug and should be reported on github.

If you open an issue make sure to be detailed on the phone specifications (GPU) and the errors, add a simple example to reproduce it too.

eons | 2019-05-26 22:10

Same thing on 3.1.1
I’ll open the issue

Pikmaan | 2019-05-26 23:03

Maybe have a look at Vertex Shading. Playing around with this in the Project Settings helped me out with a similar issue a while ago.

Coenster | 2019-06-18 15:03