2D Shadow on iOS Device

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By night76

I’m testing the lights in 2d and the occluders. If I launch the application directly from the IDE everything works well and you can also see the shadows generated by the light. If I export everything on iOS everything works, but you don’t see the shadows. Any suggestions ?

It may be a renderer bug, test with GLES2 too and try to see if there is any error on XCode.

Report any finding on github with examples so devs with iOS can fix it.

If your device is old there are chances that the issue may be already solved but for 3.2 (search issues and PRs labelled for iOS).

eons | 2019-06-04 04:45

Many devices don’t support more advanced shadows, especially using GLES2. Try using the most basic shadow you can if you arent, and test using both GLES2 and GLES3 both on the device and computer.

andersmmg | 2019-06-17 18:31

I had a similar problem with Android a while ago. What helped me was disabling the “Force Vertex shading.mobile” in the Project Settings under Rendering → Quality.

Coenster | 2019-06-18 14:39