3.2.2 TLS handshaking error on NetworkedMultiplayerENet

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By sigrud

I cannot get past the dtls error thirdparty/mbedtls/library/ssl_tls.c:5771: x509_verify_cert() returned -9984 (-0x2700) I looked it up and this is
#define MBEDTLS_ERR_X509_CERT_VERIFY_FAILED -0x2700 /**< Certificate verification failed, e.g. CRL, CA or signature check failed. *
I used the example given in the manual for using dtls with NetworkedMultiplayerENet and I have used the Crypto class, also from the manual, to make a key/cert and copied the certificate over to the other computer, I have also tried using openssl to create a certificate and still no luck. I am not sure what could be going wrong, any help would be appreciated.

Did you disable certificate validation when connecting? A self-signed ceritificate won’t be considered valid since no certificate authority is trusting it.

Calinou | 2020-08-09 21:23

Thank you, I misread that dtls_verify is false by default but it is not, I specifically set it to false and now it works, thanks for pointing me in the right direction to look.

sigrud | 2020-08-09 21:49

:bust_in_silhouette: Reply From: sigrud

dtls_verify must be set to false (default = true) when using a self-signed certificate.