3D model gets simplified once imported in engine

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By legione

Hello everyone,

I’m using Godot 3 and I’m new to the engine 3D features (I developed only a small 2D project with it so far).

I created a 3D model in Blender and exported it in both collada and obj formats, but once imported it looks like it’s getting simplified. Am I doing something wrong with the export options?

3D model in Blender (all the modifiers were applied):
3D model in Blender (all the modifiers were applied)

How the model appears in the engine:
How the model appears in the engine

I tried turning off the compression in the import settings, but it didn’t work. I’m pretty sure the geometry of the model is clean. In Unity, using the .blend files, the model is imported fine.

Thank you in advance for replying

:bust_in_silhouette: Reply From: legione

“Solved” the problem importing the mesh as gltf2. This is the result with some tweaking with the materials.

enter image description here

It looks good, I like it.

rjoshua | 2018-02-23 18:32