3D models not rendering like they do in Blender

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By daviegravee

Issue summary

My 3D models have some ugly rendering issues when I import them into Godot v3.1 from Blender v 2.73. I’d appreciate learning why they’re occurring and how to fix them.

  1. Shading/shadow issues, see this imgur album for examples;
  2. Strange visual artifacts (see here for example)

Here’s a comparison of the level as it appears in Godot vs at it appears in Blender.

I’d like to know how I can make the level render more closely to the way it does in Blender.


Here’s a link to the repo (includes the blender file)

A little more detail

I’m making a low-poly stylised golf course as a small development level while I make the assets and play with the physics for a low-poly minigolf game.

There’s some really inconsitent shading going on in the curved path of the game (see here for example). I’d like to know what i’ve done to cause this.

I’ve also noticed some weird visual artifacts in some parts of the course. These occur on the curved path and in some places where there’s overlapping geometry such as the ramps overlapping the side bumpers (see the imgur album I linked above).

I figure these issues are probably me not understanding light sources and 3D modelling well enough.

As an aside, i’m very new to 3D modelling and still quite green with Godot (this is my first project with it and i’m returning to it after a few months of being distracted). I’d appreciate people pointing out what I can do better/improve, even if it has nothing to do with the question.

  • Use better collada exporter. (enable trimesh on exporting)
  • Enable backside culling in blender so you see when face normals point in the wrong direction.
  • Disable compression when importing bigger dae meshes in godot. (major reason for gaps/inaccuracies imho)

wombatstampede | 2019-04-21 14:30