A visual artifact in tilemap

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By icqqq
:warning: Old Version Published before Godot 3 was released.

I have made my tile set and put it in tilemap.
However, I found there are some artifact between each tile.

I also tried a tile set used in godot platformer, and found there is no such artifact.
Then I tried to replace one tile in the tile set with a purple square and found the artifact appears.

The tile set I used:
enter image description here

Altered tile set in platformer game:
enter image description here

Only mipmaps is checked in the flag of texture used in tile set scene.
My game is in resolution 19201080, and my game is test in resolution 1280720.
How can I eliminate the artifacts?
And why the tiles used in the platformer game do not have artifact?

Thank you.

When you made the tileset, have you used snapping?

Looking at the tres file of the tileset and reading the numbers of the sprite positions may be easier than checking the tileset scene to be sure everything is correctly set.

eons | 2017-12-03 15:49

I don’t use snapping, but I set the translation precisely.
I will check the tres file, thanks.

icqqq | 2017-12-11 10:34