AdMob Module isn't working

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By JulioYagami

Anyone get real ads working in this module? I tried a lot and nothing for now. It shows test ads but not real ads.

Are you using a testing key? When developing a game usually you won’t get real ads and you’ll need to package it for release and use a release key to enable real ads.

andersmmg | 2019-06-08 06:00

I was using a debug key. How could I get a release key?

JulioYagami | 2019-06-17 17:26

:bust_in_silhouette: Reply From: andersmmg

First, you should try one of the keys listed here and make sure they work as they should.

Then, when you’re ready to publish your app, you’ll need to create a release key in your AdMob dashboard somewhere. I don’t have access to mine right now, but it should be pretty simple to set it up.

I tried test ads and they worked very well. I’ve created a release key but the ads didn’t work :frowning:

JulioYagami | 2019-06-17 18:07

Do they just stay as the test ads or give you some kind of error message either in the ad box or the console?

andersmmg | 2019-06-17 18:08

I am having the same problem.

I think it has something to do with the fact that you have to specify the AdMob “App ID” in the AndroidManifest.xml according to this tutorial.

I’m also stuck with this problem. Any help would be appreciated :slight_smile:

Godot_Player12 | 2019-06-24 16:07

Did you find a solution?

Godot_Player12 | 2019-06-24 16:07