Android apps won't open after first one?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By lincolnpepper

Hey, i’m trying to export android apps, and the first app i made worked fine. However, any new appds afterwards did not open. Do i need to change anything for new android projects?

A lot more information is necessary in order to help you. Did you update godot version? Are you using stable or older alpha? Did you add anything that may be causing issues in between? Did you accidentally change your export settings? Did you phone update? Is there a new dependency issue? Is there an error from the app using log cat? Are you building an apk, or you are using the build through USB button in the editor? IF you are using the build button, is it building properly and failing to launch, or is it failing during build?

I sure hope you can get this problem sorted out! But as you can see, we can’t really help unless we know more, anything we say is kind of a hit in the dark. Do you mind being more specific?

That being said, android export can be touchy at best. Some things I would try are removing the splash screen (for some reason that sometimes causes issues), checking your open gl supported version (it could be that you added a 3d feature that is not supported by your device maybe?), and resting the export settings to default.

Sojan | 2018-11-26 18:15

I’m using the newest version. I made a new app exactly identical to the old version that didn’t work. I tried messing around with export settings, but most of them had the same settings except for the package name. The phone did not update between using the apps. Not sure what dependency issue is. Sometimes it says the package is corrupt after installing, and sometimes the game won’t let you open it. I send an APK through email to use it on my phone (i couldn’t get USB to work properly). Everything so far is super simple 2D, so i can’t imagine there being problems.

Do these help? Imgur: The magic of the Internet

lincolnpepper | 2018-11-26 18:48

I also tried creating a new keystore, but it hasn’t helped.

lincolnpepper | 2018-11-26 18:49

Just curious, did you try removing the name? Or putting it like it used to be? Also if you added a version name, try putting it back as it is by default?

Also if you updated the game engine, make sure you have the matching export templates. Also, in 3.0, you are forced to use open gl 3.0 (even in 2d), which not all companies make drivers for on phones. However, I don’t think that is the issue since you say that it was working before on the same phone.

Sojan | 2018-11-26 20:57

I put everything as it used to be. It’s the second image in the imgur link.

lincolnpepper | 2018-11-26 21:08

also, i use godot on steam, which i assume updates everything when you need to.

lincolnpepper | 2018-11-26 21:09