Android export: Game flashes / Black screen / Debugger doesn't run

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By eXrump


There are similar questions, but the suggestions there do not help. After exporting to Android when the game starts, the logo flashes or black screen.

  1. Using Godot 3.0.2 plus templates 3.0.2 downloaded thru “Manage
    Export Templates”
  2. Tried both x86 and x64 version of the release
  3. Tried both 2D and 3D main scene
  4. The remote debugger doesn’t show/doesn’t run (tried both and my pc local IP)

Is there something I should change in setting maybe? Thank you.

Downloaded 2.1.4 and tried to create a similar test project. Everything works, except the remote debugger. What’s with Godot v.3? Maybe I don’t know some nuances? Thank you.

eXrump | 2018-04-06 18:42

Do your device supports GLES3? (some devices say they do but real support is not complete, like adreno based chips).

eons | 2018-04-07 02:32

Hi, thank you for replying. Mine is Mali-T830; says it supports up to OpenGL ES 3.2

eXrump | 2018-04-07 11:06

I created a simple project in Unity and forced it to use OpenGL ES 3… it does work on my phone.

eXrump | 2018-04-08 20:37

If it is Mali it should work so it could be a bug, open an issue on github with all the data you can add, device specs, logcat output, and if possible, an example project.

Comparing with Unity wont help much because we do not know what it does under the hood (it can have hacks as workaround on chip bugs).

eons | 2018-04-10 01:30