Android Module cant be found

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By gruen


i cloned the Git version of godot and followed every step of building godot from source code. After this I followed the steps for creating android modules.

Well everything worked just fine, but at the end i cant get the module with

Engine.has_singleton("TestModule") #TestModule is the name of my module

i linked it with “org/godotengine/godot/TestModule”

But Engine.has_singleton("TestModule") is still False
the documentation still says to use Globals.get_singleton but that is obsolete and didnt work too.

Well for three days now i followed everything step by steb because i thought i might forget something, but i didn’t. and it still doesnt work.

finaly i tryed this tutorial:

and again everything worked fine, but i still couldnt find the module with


and cant get it with Engine.get_singleton

i dont know what to do now. i read something of an bug, but it seems it is fixed.
so could it be that there is a new one?

did you test it on android device?
the android module is not available on desktop.

volzhs | 2019-04-08 09:37

Oh well no i didn’t

on the last video he could test it on desktop. so i will try that if i am at home (@ work right now) thanks for the hint. i will respond an update this evening.

gruen | 2019-04-08 10:36

You were right. it worked. thank you

gruen | 2019-04-09 09:46

I have the same problem but it also doesn’t work on a real device. I did everything by the instructions. Still “has_singleton” returns “false”. How Godot actually knows to automatically load the singleton? any way of debugging this thing?

bashan | 2020-04-20 19:50