Android not changing scene

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By SF123

I exported an app to android, with the correct permissions for what I needed to do, and it’s not changing the scene even though I use the correct function. The error code 19 is returned by the get_tree().change_scene("res://scene.tscn") function!

This is the third time this has happened, please help!

Thanks in advance!

what do you get if you turn on remote debugging, have the device in developer mode and run via USB cable.
Anything in the debugger other than error code 19?

deaton64 | 2021-10-13 21:03

I’ve tried doing that, and I’ve tried transferring the apk directly to my device, but it just gives me error code 19

SF123 | 2021-10-14 22:31

:bust_in_silhouette: Reply From: aXu_AP

I’m not sure what error 19 means, but one possible problem that can rise when exporting to different platforms has to do with case sensitivity on filesystem. Try to check if the path is written correctly with right casing. On Windows paths are case-insensitive, so that might explain why you haven’t encountered the error earlier.